re = /(01)(\d{14}|\d{0})(21)(\d{10}|\d{0})/
str = '01050004560134822100000000091'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end