package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(01)(\d{14}|\d{0})(21)(\d{10}|\d{0})`)
var str = `01050004560134822100000000091`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}