$re = '/(01)(\d{14}|\d{0})(21)(\d{10}|\d{0})/';
$str = '01050004560134822100000000091';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);