import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^\\x00-\\x7F\\s]+";
final String string = "// @name Preço Total - Mercado Livre\n\n"
+ "// @description Veja o preço final total no mercado livre antes de comprar um produto.Opcional = Automaticamente mostra os resultados no modo lista e organiza pelo menor preço.Mostra se o vendedor é bom (nível verde) e recomendado pelo ML ou não.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}