const regex = /[^\x00-\x7F\s]+/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^\\x00-\\x7F\\s]+', 'gmi')
const str = `// @name Preço Total - Mercado Livre
// @description Veja o preço final total no mercado livre antes de comprar um produto.Opcional = Automaticamente mostra os resultados no modo lista e organiza pelo menor preço.Mostra se o vendedor é bom (nível verde) e recomendado pelo ML ou não.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}