#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.+?Received new email message(?:(?!Received new email message)[\s\S])+?Email = testa@asd\.com"
Local $sString = "asdas wqdqw Start wqqwdsad Received new email message" & @CRLF & _
"asdasd" & @CRLF & _
"asdas" & @CRLF & _
"dasd" & @CRLF & _
"asd" & @CRLF & _
"asd" & @CRLF & _
"asdasdas Email = testa@asd.com" & @CRLF & _
"asdnaslfbasl" & @CRLF & _
"asdas wqdasdwqqeqw Start wqqwdsaadsd Received new email message" & @CRLF & _
"asdasd" & @CRLF & _
"asdas" & @CRLF & _
"dasd" & @CRLF & _
"asd" & @CRLF & _
"asd" & @CRLF & _
"asdasdasEmail = testa@asd.com" & @CRLF & _
"asdnaslfbaslasdnaslfbasl" & @CRLF & _
"asdas wqdqw Start wqqwdsad Received new email message" & @CRLF & _
"" & @CRLF & _
"asdsa" & @CRLF & _
"asdsadasd" & @CRLF & _
"asdasdasEmail = test@asd.com" & @CRLF & _
"asdnaslfbasl" & @CRLF & _
"asdas wqdqw Start wqqwdsad Received new email message" & @CRLF & _
"asdnaslfbasl" & @CRLF & _
"asdasdasEmail = test@asd.com" & @CRLF & _
"asdas wqdqw Start wqqwdsadReceived new email message" & @CRLF & _
"asda" & @CRLF & _
"as" & @CRLF & _
"asdasdasEmail = testa@asd.com" & @CRLF & _
"asdnaslfbasl" & @CRLF & _
"asdnaslfbasl" & @CRLF & _
"asdas wqdqw Start wqqwdsadReceived new email message"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")