# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^.+?Received new email message(?:(?!Received new email message)[\s\S])+?Email = testa@asd\.com"
test_str = ("asdas wqdqw Start wqqwdsad Received new email message\n"
"asdasd\n"
"asdas\n"
"dasd\n"
"asd\n"
"asd\n"
"asdasdas Email = testa@asd.com\n"
"asdnaslfbasl\n"
"asdas wqdasdwqqeqw Start wqqwdsaadsd Received new email message\n"
"asdasd\n"
"asdas\n"
"dasd\n"
"asd\n"
"asd\n"
"asdasdasEmail = testa@asd.com\n"
"asdnaslfbaslasdnaslfbasl\n"
"asdas wqdqw Start wqqwdsad Received new email message\n\n"
"asdsa\n"
"asdsadasd\n"
"asdasdasEmail = test@asd.com\n"
"asdnaslfbasl\n"
"asdas wqdqw Start wqqwdsad Received new email message\n"
"asdnaslfbasl\n"
"asdasdasEmail = test@asd.com\n"
"asdas wqdqw Start wqqwdsadReceived new email message\n"
"asda\n"
"as\n"
"asdasdasEmail = testa@asd.com\n"
"asdnaslfbasl\n"
"asdnaslfbasl\n"
"asdas wqdqw Start wqqwdsadReceived new email message")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.