use strict;
my $str = 'asdas wqdqw Start wqqwdsad Received new email message
asdasd
asdas
dasd
asd
asd
asdasdas Email = testa@asd.com
asdnaslfbasl
asdas wqdasdwqqeqw Start wqqwdsaadsd Received new email message
asdasd
asdas
dasd
asd
asd
asdasdasEmail = testa@asd.com
asdnaslfbaslasdnaslfbasl
asdas wqdqw Start wqqwdsad Received new email message
asdsa
asdsadasd
asdasdasEmail = test@asd.com
asdnaslfbasl
asdas wqdqw Start wqqwdsad Received new email message
asdnaslfbasl
asdasdasEmail = test@asd.com
asdas wqdqw Start wqqwdsadReceived new email message
asda
as
asdasdasEmail = testa@asd.com
asdnaslfbasl
asdnaslfbasl
asdas wqdqw Start wqqwdsadReceived new email message';
my $regex = qr/^.+?Received new email message(?:(?!Received new email message)[\s\S])+?Email = testa@asd\.com/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}