import Foundation
let pattern = #"^.+?Received new email message(?:(?!Received new email message)[\s\S])+?Email = testa@asd\.com"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
asdas wqdqw Start wqqwdsad Received new email message
asdasd
asdas
dasd
asd
asd
asdasdas Email = testa@asd.com
asdnaslfbasl
asdas wqdasdwqqeqw Start wqqwdsaadsd Received new email message
asdasd
asdas
dasd
asd
asd
asdasdasEmail = testa@asd.com
asdnaslfbaslasdnaslfbasl
asdas wqdqw Start wqqwdsad Received new email message
asdsa
asdsadasd
asdasdasEmail = test@asd.com
asdnaslfbasl
asdas wqdqw Start wqqwdsad Received new email message
asdnaslfbasl
asdasdasEmail = test@asd.com
asdas wqdqw Start wqqwdsadReceived new email message
asda
as
asdasdasEmail = testa@asd.com
asdnaslfbasl
asdnaslfbasl
asdas wqdqw Start wqqwdsadReceived new email message
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)