using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https?:\/\/(\w+\.)?imgur.com\/(\w*\d\w*)+(\.(png|jpg|gif|PNG|JPG|GIF|jpeg))?";
string input = @"
https://imgur.com/gallery/kbRSjdw
test
https://i.imgur.com/zeOe49Q.jpeg
https://i.imgur.com/2M7LmOO.png";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}