import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "https?:\\/\\/(\\w+\\.)?imgur.com\\/(\\w*\\d\\w*)+(\\.(png|jpg|gif|PNG|JPG|GIF|jpeg))?";
final String string = "\n"
+ "https://imgur.com/gallery/kbRSjdw\n\n"
+ "test\n\n\n"
+ "https://i.imgur.com/zeOe49Q.jpeg\n\n"
+ "https://i.imgur.com/2M7LmOO.png";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}