// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)https?:\/\/(\w+\.)?imgur.com\/(\w*\d\w*)+(\.(png|jpg|gif|PNG|JPG|GIF|jpeg))?").unwrap();
let string = "
https://imgur.com/gallery/kbRSjdw
test
https://i.imgur.com/zeOe49Q.jpeg
https://i.imgur.com/2M7LmOO.png";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}