#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:AA|BB)\s{2,}(\S.*?)\s{2,}(\S+)"
Local $sString = "||/ software version some_text Description" & @CRLF & _
"+++-======================================-===================================================-============-===============================================================================" & @CRLF & _
"AA SOFTWARE1 this is some text 1.1.1.1-UBUNTU GHGFHGFH Description1" & @CRLF & _
"AA SOFTWARE2 1.1.1.2-UBUNTU_HGSFHF JGJHGKGK Description2" & @CRLF & _
"BB SOFTWARE3 1.2.3.4.5 JHGJHGJG Description3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")