# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:AA|BB)\s{2,}(\S.*?)\s{2,}(\S+)"
test_str = ("||/ software version some_text Description\n"
"+++-======================================-===================================================-============-===============================================================================\n"
"AA SOFTWARE1 this is some text 1.1.1.1-UBUNTU GHGFHGFH Description1\n"
"AA SOFTWARE2 1.1.1.2-UBUNTU_HGSFHF JGJHGKGK Description2\n"
"BB SOFTWARE3 1.2.3.4.5 JHGJHGJG Description3")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.