$re = '/^(?:AA|BB)\s{2,}(\S.*?)\s{2,}(\S+)/m';
$str = '||/ software version some_text Description
+++-======================================-===================================================-============-===============================================================================
AA SOFTWARE1 this is some text 1.1.1.1-UBUNTU GHGFHGFH Description1
AA SOFTWARE2 1.1.1.2-UBUNTU_HGSFHF JGJHGKGK Description2
BB SOFTWARE3 1.2.3.4.5 JHGJHGJG Description3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);