package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:AA|BB)\s{2,}(\S.*?)\s{2,}(\S+)`)
var str = `||/ software version some_text Description
+++-======================================-===================================================-============-===============================================================================
AA SOFTWARE1 this is some text 1.1.1.1-UBUNTU GHGFHGFH Description1
AA SOFTWARE2 1.1.1.2-UBUNTU_HGSFHF JGJHGKGK Description2
BB SOFTWARE3 1.2.3.4.5 JHGJHGJG Description3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}