using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[A-Za-z0-9_]+\.[A-Za-z0-9_]+\s*={2}\s*[A-Za-z0-9_]+";
string input = @"a.B == c
I_amACasr2.Toyota == mazda
mouth.nose == head
[anylettersOrNumbers(without_symbol(.)].[anylettersOrNumbers(without_symbol(.)] == anylettersOrNumbers(without_symbol(.)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}