package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[A-Za-z0-9_]+\.[A-Za-z0-9_]+\s*={2}\s*[A-Za-z0-9_]+`)
var str = `a.B == c
I_amACasr2.Toyota == mazda
mouth.nose == head
[anylettersOrNumbers(without_symbol(.)].[anylettersOrNumbers(without_symbol(.)] == anylettersOrNumbers(without_symbol(.)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}