// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[A-Za-z0-9_]+\.[A-Za-z0-9_]+\s*={2}\s*[A-Za-z0-9_]+").unwrap();
let string = "a.B == c
I_amACasr2.Toyota == mazda
mouth.nose == head
[anylettersOrNumbers(without_symbol(.)].[anylettersOrNumbers(without_symbol(.)] == anylettersOrNumbers(without_symbol(.)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}