$re = '/[A-Za-z0-9_]+\.[A-Za-z0-9_]+\s*={2}\s*[A-Za-z0-9_]+/m';
$str = 'a.B == c
I_amACasr2.Toyota == mazda
mouth.nose == head
[anylettersOrNumbers(without_symbol(.)].[anylettersOrNumbers(without_symbol(.)] == anylettersOrNumbers(without_symbol(.)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);