#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^profile[0-9]+\.name(?==)"
Local $sString = "profile2.name=share2" & @CRLF & _
"profile8.name=share8" & @CRLF & _
"profile4.name=shareSSH" & @CRLF & _
"profile9.name=share9" & @CRLF & _
"" & @CRLF & _
"my: ^profile[0-9]\.name=(.*?)" & @CRLF & _
" ^profile[0-9]+\.name(?==)" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")