re = /^profile[0-9]+\.name(?==)/m
str = 'profile2.name=share2
profile8.name=share8
profile4.name=shareSSH
profile9.name=share9
my: ^profile[0-9]\\.name=(.*?)
^profile[0-9]+\\.name(?==)
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end