use strict;
my $str = 'profile2.name=share2
profile8.name=share8
profile4.name=shareSSH
profile9.name=share9
my: ^profile[0-9]\\.name=(.*?)
^profile[0-9]+\\.name(?==)
';
my $regex = qr/^profile[0-9]+\.name(?==)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}