const regex = new RegExp('^profile[0-9]+\\.name(?==)', 'gm')
const str = `profile2.name=share2
profile8.name=share8
profile4.name=shareSSH
profile9.name=share9
my: ^profile[0-9]\\.name=(.*?)
^profile[0-9]+\\.name(?==)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}