#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?P<text>.*?)(?P<index>{ *{ *([^}{]+?) *} *})"
Local $sString = "Мы вынуждены отталкиваться от того, что высокотехнологичная концепция общественного уклада обеспечивает актуальность{{1}}приоритизации разума над эмоциями. В своём стремлении повысить качество жизни, они забывают,{ {1}} что семантический разбор внешних противодействий, в своём классическом представлении, допускает внедрение стандартных подходов. В своём стремлении повысить качество жизни, они забывают, что современная методология разработки создаёт необходимость включения в производственный план целого ряда{{1} } внеочередных мероприятий с учётом комплекса кластеризации усилий. Непосредственные участники технического прогресса ограничены исключительно образом мышления. Каждый из нас понимает очевидную вещь: { {1 7 7} }выбранный нами инновационный путь способствует подготовке и реализации приоритизации разума над эмоциями.{{ 1} }"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")