use strict;
my $str = 'Мы вынуждены отталкиваться от того, что высокотехнологичная концепция общественного уклада обеспечивает актуальность{{1}}приоритизации разума над эмоциями. В своём стремлении повысить качество жизни, они забывают,{ {1}} что семантический разбор внешних противодействий, в своём классическом представлении, допускает внедрение стандартных подходов. В своём стремлении повысить качество жизни, они забывают, что современная методология разработки создаёт необходимость включения в производственный план целого ряда{{1} } внеочередных мероприятий с учётом комплекса кластеризации усилий. Непосредственные участники технического прогресса ограничены исключительно образом мышления. Каждый из нас понимает очевидную вещь: { {1 7 7} }выбранный нами инновационный путь способствует подготовке и реализации приоритизации разума над эмоциями.{{ 1} }';
my $regex = qr/(?P<text>.*?)(?P<index>{ *{ *([^}{]+?) *} *})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}