// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?P<text>.*?)(?P<index>{ *{ *([^}{]+?) *} *})").unwrap();
let string = "Мы вынуждены отталкиваться от того, что высокотехнологичная концепция общественного уклада обеспечивает актуальность{{1}}приоритизации разума над эмоциями. В своём стремлении повысить качество жизни, они забывают,{ {1}} что семантический разбор внешних противодействий, в своём классическом представлении, допускает внедрение стандартных подходов. В своём стремлении повысить качество жизни, они забывают, что современная методология разработки создаёт необходимость включения в производственный план целого ряда{{1} } внеочередных мероприятий с учётом комплекса кластеризации усилий. Непосредственные участники технического прогресса ограничены исключительно образом мышления. Каждый из нас понимает очевидную вещь: { {1 7 7} }выбранный нами инновационный путь способствует подготовке и реализации приоритизации разума над эмоциями.{{ 1} }";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}