#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=\b.{12}\b)(?=\b[a-z0-9]*[A-Z][a-z0-9]*\b)(?=\b[a-zA-Z]*[0-9][a-zA-Z]*\b)\b\w{12}\b"
Local $sString = "Generalken0b Generalken0bi generalken0b" & @CRLF & _
"" & @CRLF & _
"General" & @CRLF & _
"ken0b" & @CRLF & _
"" & @CRLF & _
"Generalk3n0b" & @CRLF & _
"" & @CRLF & _
"Generalkenob" & @CRLF & _
"" & @CRLF & _
"G3neralkenob" & @CRLF & _
"" & @CRLF & _
"ggggggggggg0 ggggggggggG0 GeneralKen0b" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"A5abcdefghij - match" & @CRLF & _
"" & @CRLF & _
"dasdaA4avxsa - match" & @CRLF & _
"" & @CRLF & _
"AA5sssaaaaaa - no match" & @CRLF & _
"" & @CRLF & _
"A55asdasdasa - no match" & @CRLF & _
"" & @CRLF & _
"ab5DaeFsasfg - no match"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")