$re = '/(?=\b.{12}\b)(?=\b[a-z0-9]*[A-Z][a-z0-9]*\b)(?=\b[a-zA-Z]*[0-9][a-zA-Z]*\b)\b\w{12}\b/m';
$str = 'Generalken0b Generalken0bi generalken0b
General
ken0b
Generalk3n0b
Generalkenob
G3neralkenob
ggggggggggg0 ggggggggggG0 GeneralKen0b
A5abcdefghij - match
dasdaA4avxsa - match
AA5sssaaaaaa - no match
A55asdasdasa - no match
ab5DaeFsasfg - no match';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);