import re
regex = re.compile(r"(?=\b.{12}\b)(?=\b[a-z0-9]*[A-Z][a-z0-9]*\b)(?=\b[a-zA-Z]*[0-9][a-zA-Z]*\b)\b\w{12}\b", flags=re.MULTILINE)
test_str = ("Generalken0b Generalken0bi generalken0b\n\n"
"General\n"
"ken0b\n\n"
"Generalk3n0b\n\n"
"Generalkenob\n\n"
"G3neralkenob\n\n"
"ggggggggggg0 ggggggggggG0 GeneralKen0b\n\n\n"
"A5abcdefghij - match\n\n"
"dasdaA4avxsa - match\n\n"
"AA5sssaaaaaa - no match\n\n"
"A55asdasdasa - no match\n\n"
"ab5DaeFsasfg - no match")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")