using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(.*?)>";
string input = @"Francesco Renga <francesco_renga-001@gmail.com>, Marty McFly <mmcfly@gmail.com>
Marty McFly <mmcfly@gmail.com>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}