$re = '/<(.*?)>/';
$str = 'Francesco Renga <francesco_renga-001@gmail.com>, Marty McFly <mmcfly@gmail.com>
Marty McFly <mmcfly@gmail.com>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);