re = /<(.*?)>/
str = 'Francesco Renga <francesco_renga-001@gmail.com>, Marty McFly <mmcfly@gmail.com>
Marty McFly <mmcfly@gmail.com>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end