#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\s*\d+\s*(?:units?|times?(?:\s+(?:a|per)\s+|\s*/\s*)(?:d(?:ay)?|w(?:ee)?k|month|y(?:ea)?r?))"
Local $sString = "inJECTable 1234 Eprex DOSE 4000 units on NONd" & @CRLF & _
"department 6789 DOSE 8000 units on DIALYSIS days - IV Interm'," & @CRLF & _
"inJECTable 4321 Eprex DOSE - 3 times/wk on NONdialysis day'," & @CRLF & _
"insulin MixTARD 30/70 - inJECTable 46 units'," & @CRLF & _
"insulin ISOPHANE -- InsulaTARD Vial - inJECTable 56 units SC SubCutaneous'," & @CRLF & _
"1-alfacalcidol DOSE 1 mcg - 3 times a week - IV Intermittent'," & @CRLF & _
"jevity liquid - FEEDS PO Jevity - 237 mL - 1 times per day'," & @CRLF & _
"1-alfacalcidol DOSE 1 mcg - 3 times per week - IV Intermittent'," & @CRLF & _
"1-supported DOSE 1 mcg - 1 time/day - IV Intermittent'," & @CRLF & _
"1-testpackage DOSE 1 mcg - 1 time a day - IV Intermittent" & @CRLF & _
"" & @CRLF & _
"///3 times a day, 3 time/wk, 3 times per day, 3 times a month, 3 times/month"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)