# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\s*\d+\s*(?:units?|times?(?:\s+(?:a|per)\s+|\s*/\s*)(?:d(?:ay)?|w(?:ee)?k|month|y(?:ea)?r?))"
test_str = ("inJECTable 1234 Eprex DOSE 4000 units on NONd\n"
"department 6789 DOSE 8000 units on DIALYSIS days - IV Interm',\n"
"inJECTable 4321 Eprex DOSE - 3 times/wk on NONdialysis day',\n"
"insulin MixTARD 30/70 - inJECTable 46 units',\n"
"insulin ISOPHANE -- InsulaTARD Vial - inJECTable 56 units SC SubCutaneous',\n"
"1-alfacalcidol DOSE 1 mcg - 3 times a week - IV Intermittent',\n"
"jevity liquid - FEEDS PO Jevity - 237 mL - 1 times per day',\n"
"1-alfacalcidol DOSE 1 mcg - 3 times per week - IV Intermittent',\n"
"1-supported DOSE 1 mcg - 1 time/day - IV Intermittent',\n"
"1-testpackage DOSE 1 mcg - 1 time a day - IV Intermittent\n\n"
"///3 times a day, 3 time/wk, 3 times per day, 3 times a month, 3 times/month")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.