// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\s*\d+\s*(?:units?|times?(?:\s+(?:a|per)\s+|\s*/\s*)(?:d(?:ay)?|w(?:ee)?k|month|y(?:ea)?r?))").unwrap();
let string = "inJECTable 1234 Eprex DOSE 4000 units on NONd
department 6789 DOSE 8000 units on DIALYSIS days - IV Interm',
inJECTable 4321 Eprex DOSE - 3 times/wk on NONdialysis day',
insulin MixTARD 30/70 - inJECTable 46 units',
insulin ISOPHANE -- InsulaTARD Vial - inJECTable 56 units SC SubCutaneous',
1-alfacalcidol DOSE 1 mcg - 3 times a week - IV Intermittent',
jevity liquid - FEEDS PO Jevity - 237 mL - 1 times per day',
1-alfacalcidol DOSE 1 mcg - 3 times per week - IV Intermittent',
1-supported DOSE 1 mcg - 1 time/day - IV Intermittent',
1-testpackage DOSE 1 mcg - 1 time a day - IV Intermittent
///3 times a day, 3 time/wk, 3 times per day, 3 times a month, 3 times/month";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}