#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:Tweak|Dev|Feature)\s+-(?:\s+(?:#?\w+|http\S*)){3,}\.?$"
Local $sString = "Tweak - this should be correct." & @CRLF & _
"Feature - my feature having a special character as #123." & @CRLF & _
"Dev - this should also work https://regex101.com/" & @CRLF & _
"" & @CRLF & _
"Dev-Hello world" & @CRLF & _
"incorrect" & @CRLF & _
"Tweak- it should be wrong" & @CRLF & _
"feature - it is also incorrect"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")