use strict;
my $str = 'Tweak - this should be correct.
Feature - my feature having a special character as #123.
Dev - this should also work https://regex101.com/
Dev-Hello world
incorrect
Tweak- it should be wrong
feature - it is also incorrect';
my $regex = qr/^(?:Tweak|Dev|Feature)\s+-(?:\s+(?:#?\w+|http\S*)){3,}\.?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}