// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:Tweak|Dev|Feature)\s+-(?:\s+(?:#?\w+|http\S*)){3,}\.?$").unwrap();
let string = "Tweak - this should be correct.
Feature - my feature having a special character as #123.
Dev - this should also work https://regex101.com/
Dev-Hello world
incorrect
Tweak- it should be wrong
feature - it is also incorrect";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}