$re = '/^(?:Tweak|Dev|Feature)\s+-(?:\s+(?:#?\w+|http\S*)){3,}\.?$/m';
$str = 'Tweak - this should be correct.
Feature - my feature having a special character as #123.
Dev - this should also work https://regex101.com/
Dev-Hello world
incorrect
Tweak- it should be wrong
feature - it is also incorrect';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);