using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\s*(<([^\s<>]+)[^<>]*>)Apple<\/\2>";
string input = @"<div class=""tn-atom"" field=""tn_text_1584898828640"" target=""_blank"">Apple</div>
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}