import re
regex = re.compile(r"^\s*(<([^\s<>]+)[^<>]*>)Apple<\/\2>", flags=re.MULTILINE)
test_str = ("<div class=\"tn-atom\" field=\"tn_text_1584898828640\" target=\"_blank\">Apple</div>\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")