$re = '/^\s*(<([^\s<>]+)[^<>]*>)Apple<\/\2>/m';
$str = '<div class="tn-atom" field="tn_text_1584898828640" target="_blank">Apple</div>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);