using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-Za-zÀ-ÖØ-öø-ÿĀ-ſƀ-ɏ0-9]*$";
string input = @"testŒéøç123";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}