$re = '/^[A-Za-zÀ-ÖØ-öø-ÿĀ-ſƀ-ɏ0-9]*$/';
$str = 'testŒéøç123';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);