package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[A-Za-zÀ-ÖØ-öø-ÿĀ-ſƀ-ɏ0-9]*$`)
var str = `testŒéøç123`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}