import re
regex = re.compile(r"^[A-Za-zÀ-ÖØ-öø-ÿĀ-ſƀ-ɏ0-9]*$")
test_str = "testŒéøç123"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")