#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[A-Z]{2,}(?=[A-Z][a-z]|\b)|[A-Z][a-z]*"
Local $sString = "Last First Middle" & @CRLF & _
"" & @CRLF & _
"LAST First Middle" & @CRLF & _
"" & @CRLF & _
"Last FirstMiddle" & @CRLF & _
"" & @CRLF & _
"LAST FirstMiddle" & @CRLF & _
"" & @CRLF & _
"LastFirst Middle" & @CRLF & _
"" & @CRLF & _
"LASTFirst Middle" & @CRLF & _
"" & @CRLF & _
"LastFirstMiddle" & @CRLF & _
"" & @CRLF & _
"LASTFirstMiddle"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")