import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[A-Z]{2,}(?=[A-Z][a-z]|\\b)|[A-Z][a-z]*";
final String string = "Last First Middle\n\n"
+ "LAST First Middle\n\n"
+ "Last FirstMiddle\n\n"
+ "LAST FirstMiddle\n\n"
+ "LastFirst Middle\n\n"
+ "LASTFirst Middle\n\n"
+ "LastFirstMiddle\n\n"
+ "LASTFirstMiddle";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}