re = /[A-Z]{2,}(?=[A-Z][a-z]|\b)|[A-Z][a-z]*/m
str = 'Last First Middle
LAST First Middle
Last FirstMiddle
LAST FirstMiddle
LastFirst Middle
LASTFirst Middle
LastFirstMiddle
LASTFirstMiddle'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end